Enable add-ons for recent version of Firefox minefield

I am using the trunk version of firefox a lot because it’s much faster than the current official version.

Recently the preference to enable old versions of extensions in firefox has been changed:
extensions.checkCompatibility
has been renamed to
extensions.checkCompatibility.VERSION
With the current version being 3.7a or new 4.0b the preference key is
extensions.checkCompatibility.3.7a
extensions.checkCompatibility.4.0b

Setting this preference key to the boolean value false will allow you to enable add-ons that are not tagged as compatible with the current development version of firefox. Of course because of possible API changes, especially in Version 4 some plugins may be broken, but for me all add-ons I use still work on the nightly builds.

1 comment

  1. Thanks for this post, I was about to wonder what had happened with the new updates rolling out on Minefield 4.0b9pre, I guess somewhere along the line they reset the value I already had back to true, so I just did this and it worked.

    Phew!

Leave a comment

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.